ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2012-77
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
perl-ogl
概要
任意のHTTPヘッダの挿入の可能性等
危険度
1
 
 
 
2 詳細
 
 スクリプト言語 perl にセキュリティ脆弱性が指摘されています。これは CGI.pm を使った場合に HTTP で任意のヘッダを挿入できてしまう問題、x 演算子を使用した場合にクラッシュさせることができてしまう等の複数の問題です。
 これらの問題の詳細な情報については以下の URL をご参照ください。
 
「CVE-2012-5526」 Common Vulnerabilities and Exposures
 
「CVE-2012-5195」 Common Vulnerabilities and Exposures
 
「CVE-2011-3597」 Common Vulnerabilities and Exposures
 
「CVE-2011-2939」 Common Vulnerabilities and Exposures
 
 
 アップデート後の perl-ogl 関連パッケージのバージョンは 5.10.1-17squeeze4o101 に上がります。
 
 
3 対処方法
 
 root になり下記のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install perl
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp