ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2011-46
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
perl
概要
文字列を介した任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 スクリプト言語 perl に標準で含まれるライブラリにセキュリティ脆弱性が指摘されています。これは細工された文字列を、lc/lcfirst/uc/ucfirst 関数を使用した perl スクリプトが処理した場合、任意のコードを実行させられてしまう可能性がある、という問題です。
 この問題の詳細についは以下の URL をご参照ください。
 
「CVE-2011-1487」 Common Vulnerabilities and Exposures
 
 
 アップデート後の perl 関連パッケージのバージョンは 5.10.1-17squeeze1o101 に上がります。
 
 
3 対処方法
 
 root になり下記のようにアップデートをおこなってください。
 
 
# apt-get install perl
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp