ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2011-27
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
apache2-ogl
概要
権限昇格の可能性
危険度
1
 
 
 
2 詳細
 
 Web サーバの Apache2 にセキュリティ脆弱性が指摘されています。これは apache2-mpm-itk を使用している場合で、設定ファイルで NiceValue ディレクティブを設定し、かつ AssignUserID ディレクティブを設定していない場合に、apache2 が特権ユーザーで実行されてしまうという問題です。
 標準の状態では apache2-mpm-ipk はインストールされず、NiceValue ディレクティブも設定されていません。該当するパッケージ構成および設定で使用している場合のみアップデートが必要となります。
 この問題のより詳しい情報については以下を参照してください。
 
「DSA-2202-1 -- failure to drop root privileges」
 
 
 アップデート後の apache2 関連パッケージのバージョンは 2.2.17-2o101 に上がります。
 
 
3 対処方法
 
 apache2-mpm-itk を使用している場合は root になり下記のようにインストールをおこなってください。その他の場合はアップデートは特に必要ありません。
 
 
# apt-get update
# apt-get install apache2.2-bin
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp