ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2011-20
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
webkit
概要
HTMLを通じた任意のコード実行の可能性他
危険度
1
 
 
 
2 詳細
 
 Web コンテンツライブラリの WebKit にセキュリティ脆弱性が指摘されています。これはアプリケーションが悪意を持って細工された HTML を処理した場合に任意のコードを実行させられてしまう可能性等、複数の脆弱性を含むものです。アップデートの詳細については下記を参照してください。
 
「CVE-2010-1783」 Common Vulnerabilities and Exposures
 
「CVE-2010-2901」 Common Vulnerabilities and Exposures
 
「CVE-2010-4199」 Common Vulnerabilities and Exposures
 
「CVE-2010-4040」 Common Vulnerabilities and Exposures
 
「CVE-2010-4492」 Common Vulnerabilities and Exposures
 
「CVE-2010-4493」 Common Vulnerabilities and Exposures
 
「CVE-2010-4577」 Common Vulnerabilities and Exposures
 
「CVE-2010-4578」 Common Vulnerabilities and Exposures
 
「CVE-2011-0482」 Common Vulnerabilities and Exposures
 
「CVE-2011-0778」 Common Vulnerabilities and Exposures
 
 
 アップデート後の WebKit 関連パッケージのバージョンは 1.2.7-0+squeeze1o1 に上がります。また本ライブラリは ARMA では主に yelp (GNOME ヘルプブラウザ) が使用しており、yelp のバージョンも 2.30.0+webkit-1o1 に上がります。
 
 
3 対処方法
 
 root になり下記のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install llibwebkit-1.0-2 yelp
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp