ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2010-20
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
libtool
概要
任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 dlopen ラッパーの libtool にセキュリティ脆弱性が指摘されています。これはカレントディレクトリにある .la ファイルを使用することで意図しないダイナミックリンクライブラリを読み込ませることが可能になるという問題です。
 この問題のより詳しい情報については以下を参照してください。
 
「CVE-2009-3736」 Common Vulnerabilities and Exposures
 
 
 アップデート後の libtool パッケージのバージョンは 2.2.6b-2o1 に上がります。
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install libltdl7
 
 
 libtool もインストールしている場合は下記のインストールも追加しておこなってください。
 
 
# apt-get install libtool
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp