ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2009-23
 
 
1 サマリ
 
 
対象システム
ARMA2.1,ARMA2.2
パッケージ
imagemagick-ogl
概要
画像ファイルを通じた任意コード実行の可能性
危険度
1
 
 
 
2 詳細
 
 画像編集、表示ツールである imagemagick に脆弱性が指摘されています。悪意をもって細工をされたファイルを読み込んだ場合に imagemagick に含まれるコマンドもしくは libmagick に依存しているコマンドを実行したユーザーの権限で任意のコードを実行される可能性があります。
 詳細は以下の URL をご参照下さい。
 
「CVE-2007-1667」 Common Vulnerabilities and Exposures
 
「CVE-2007-1797」 Common Vulnerabilities and Exposures
 
「CVE-2007-4985」 Common Vulnerabilities and Exposures
 
「CVE-2007-4986」 Common Vulnerabilities and Exposures
 
「CVE-2007-4987」 Common Vulnerabilities and Exposures
 
「CVE-2007-4988」 Common Vulnerabilities and Exposures
 
「CVE-2008-1096」 Common Vulnerabilities and Exposures
 
「CVE-2008-1097」 Common Vulnerabilities and Exposures
 
 
 ARMA 2.2 ではバージョン 5.5.7.9-1o901 で、ARMA 2.0, 2.1 ではバージョン 5.4.6.3-2o1001で対応を行なっています。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行しパッケージのアップデートを行って下さい。
 
 
# apt-get update
# apt-get install imagemagick
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp