ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2008-43
 
 
1 サマリ
 
 
対象システム
ARMA2.2
パッケージ
enscript-ogl
概要
ローカルでの任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 テキストファイルを PostScript, HTML など他のフオーマットに変換するフィルタの enscript に複数のバッファオーバーフロー脆弱性が指摘されています。不正に細工された入力を与えた場合に任意のコードを実行される可能性があります。
 詳細は以下の URL をご参照ください。
 
「CVE-2008-3863」 Common Vulnerabilities and Exposures
 
「CVE-2008-4306」 Common Vulnerabilities and Exposures
 
 
 アップデート後のパッケージのバージョンは 1.6.4-6o201 になります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行してください。
 
 
# apt-get update
# apt-get install enscript
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp