ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2008-14
 
 
1 サマリ
 
 
対象システム
ARMA2.1,ARMA2.2
パッケージ
pcre3
概要
リモートからの任意のコード実行の可能性
危険度
2
 
 
 
2 詳細
 
 Perl 互換正規表現ライブラリの PCRE にセキュリティ脆弱性が指摘されています。特定の条件を満す正規表現をライブラリに与えた場合にバッファオーバーフローが発生し、アプリケーションを介して任意のコードを実行させられてしまう可能性があります。
 この問題に関するより詳しい情報については以下を参照してください
 
「CVE-2008-0674」 Common Vulnerabilities and Exposures http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0674
 
 
 アップデート後の PCRE 関連パッケージのバージョンは 4.5+7.4-2o1 に上がります。
 
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get install libpcre3
 
 
 
 また libpcre3 を使っているアプリケーションも再起動をおこなってください。特に Apache を使用している場合は再起動をおこなうようにしてください。以下がコマンドラインの例となります。
 
 
# /etc/init.d/apache restart
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp