ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2007-7
 
 
1 サマリ
 
 
対象システム
ARMA2.2, ARMA2.1
パッケージ
libgtop2, libgtop
概要
ローカルユーザーからの任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 GNOME デスクトップのシステムモニタライブラリである libgtop2/libgtop に、セキュリティ脆弱性が指摘されています。これは悪意をもって細工された非常に長いファイル名を、libgtop2/libgtop を使用したアプリケーションが処理した場合に、任意のコードを実行させられてしまう可能性があるという問題です。
 この問題のより詳しい情報については以下を参照してください。
 
「CVE-2007-0235」- Common Vulnerabilities and Exposures
 
 
 アップデート後の libgtop2 のバージョンは 2.0.1-4o101 に、libgtop のバージョンは 1.0.13-4o101 に上がります。
 
 
3 対処方法
 
 ARMA2.2 をご利用の場合、root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install libgtop2
 
 
 ARMA2.1 をご利用の場合、以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install libgtop1
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp