ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2007-24
 
 
1 サマリ
 
 
対象システム
ARMA2.1,ARMA2.2
パッケージ
php4-ogl
概要
任意の ftp コマンド実行の可能性
危険度
2
 
 
 
2 詳細
 
 HTML埋め込み言語の PHP4 にセキュリティ脆弱性が指摘されています。スクリプトが ftp_putcmd を使用している場合リモートから任意の ftp コマンドを実行させられてしまう可能性が指摘されています。
 この問題についてのより詳しい情報は以下を参照してください。
 
「CVE-2007-2509」 Common Vulnerabilities and Exposures
 
 
 アップデート後の PHP4 関連パッケージのバージョンは ARMA2.2 では 4.3.10-16o601 に、ARMA2.1 では 4.2.3-3o901 に上がります。
 
 
3 対処方法
 
 php4 を利用している場合は以下のようにアップデートをおこなってください。PHP4 を利用しているのは通常サーバ版のみとなります。
 
ARMA 2.2 の場合
 
# apt-get update
# apt-get install php4 php4-cgi php4-curl php4-dev php4-domxml 
      php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-odbc 
      php4-pear php4-pgsql php4-recode php4-snmp
 
 
ARMA 2.1 の場合
 
# apt-get update
# apt-get install php4 php4-cgi php4-curl php4-dev php4-domxml 
      php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-odbc 
      php4-pear php4-recode php4-snmp
 
 
 
 いずれの場合も apt-get コマンドは改行を入れずに一行に記述してください。

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp