ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2006-9
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
libtasn1
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 データ構造定義言語である ASN.1 の実装である libtasn1 に脆弱性が報告されています。DER でのエンコード、デコード処理のバグが原因で、悪意をもって細工をされたデータを処理した場合にライブラリを使用しているユーザの権限で任意のコードを実行をされる可能性があります。詳細は以下の URL をご参照下さい。
  
 
「CVE-2006-0645」 Common Vulnerabilities and Exposures
 
 
 アップデート後の libtasn1 の関連パッケージのバージョンは 0.1.2-1o101 になります。
 
 
3 対処方法
 
 root 権限で以下のコマンド実行しパッケージのアップデートをおこなって下さい。libtasn1.so の API が一部変更になるため libgnutls5 のアップデートも同時におこないます。
 
 
# apt-get update
# apt-get install libtasn1-0 libgnutls5
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp