ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2006-22
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
lynx-ja
概要
入力チェックの不足
危険度
1
 
 
 
2 詳細
 
 テキストベースの Web ブラウザの Lynx-ja にセキュリティ脆弱性が指摘されています。これは (1) COLS の大きい TEXTAREA を使用した場合、あるいは(2)閉じられていないエレメントの長い名前のタグを使用した HTML を読み込んだ場合に、Lynx-ja が無限ループに陥ってしまう、という問題です。
 この問題の詳細については以下の情報を参照してください。
 
「CVE-2004-1617」 Common Vulnerabilities and Exposures
 
 
 アップデート後の lynx-ja 関連パッケージのバージョンは 2.8.4-1.9o201 に上がります。
 
 
3 対処方法
 
 システムに lyna-ja パッケージがインストールされている場合は、root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update 
# apt-get install lynx-ja
 
 
 当該パッケージがインストールされていない場合は対応の必要はありません。また lynx-ja が不要なシステムでは lynx-ja をアンインストールしてもかまいません。その場合は以下のように実行してください。
 
 
# apt-get remove --purge lynx-ja
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp