ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-77
 
 
1 サマリ
 
 
対象システム
ARAM2.0,ARMA2.1,ARMA2.2
パッケージ
libungif4-ogl
概要
画像ファイルを介した任意コード実行の可能性
危険度
1
 
 
 
2 詳細
 
 GIF 形式の画像を扱うライブラリの libungif4 に複数の脆弱性が指摘されています。悪意をもって細工されたファイルをアプリケーションが処理した場合に任意のコードを実行させられてしまう可能性があります。詳細は以下の URL をご参照下さい。
 
「CVE-2005-2974」 Common Vulnerabilities and Exposures
 
「CVE-2005-3350」 Common Vulnerabilities and Exposures
 
 
 アップデート後の libungif4 関連パッケージのバージョンは ARMA 2.2 では 4.1.0b1-4o101に、ARMA2.1/2.0 では 4.1.0b1-2woody1o1 に上がります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行しパッケージのアップデートをおこなって下さい。
 
 
# apt-get  update
# apt-get  install libungif4g
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp