ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-71
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
ruby
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 オブジェクト指向スクリプト言語の Ruby に脆弱性が指摘されています。外部からの入力チェックを言語レベルで迂回される場合があります。そのためチェックを迂回した入力を直接実行した場合に任意コードの実行につながる可能性があります。
 この問題についてより詳しい情報は以下を参照してください。
 
 
「CAN-2005-2337」 Common Vulnerabilities and Exposures
 
 
 アップデート後の ruby 関連パッケージのバージョンは ARMA2.2 では 1.6.8-3o301、ARMA2.1/2.0 では 1.6.7-4o301 となります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行しパッケージのアップデートをおこなってください。
 
 
# apt-get update
# apt-get install ruby
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp