ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-37
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
cvs-ogl
概要
pserverの認証回避他
危険度
2
 
 
 
2 詳細
 
 バージョン管理システムの CVS にセキュリティ脆弱性が指摘されています。この問題は2点あり、1点は pserver 使用時に認証を回避できてしまう可能性の問題、もう1点は cvs-repouids を使用してリポジトリの UID をマップしたときに DoS 攻撃が可能となってしまう問題です。
 この問題についてより詳しい情報については以下を参照してください。
 
「CAN-2004-1342」 Common Vulnerabilities and Exposures
 
「CAN-2004-1343」 Common Vulnerabilities and Exposures
 
 
 アップデート後の cvs のバージョンは 1.12.9-0o201 に上がります。
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install cvs
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp