ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-18
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
python2.2
概要
リモートからの意図しないデータアクセス
危険度
2
 
 
 
2 詳細
 
 オブジェクト指向言語の Python にセキュリティ脆弱性が指摘されています。これは SimpleXMLRPCServer モジュールを使用した場合に、リモートに対して想定していないオブジェクト(データ)にアクセスできてしまう、という問題です。
 この問題についての詳細は以下の情報を参照してください。
 
「CAN-2005-0077」 Common Vulnerabilities and Exposures
 
 
 アップデート後の python2.2 のバージョンは ARMA2.2 では 2.2.2-5o101 に、ARMA2.1 では 2.2.1-5o401 にあがります。
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install python2.2
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp