ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-17
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
cpio
概要
パーミションの破損
危険度
1
 
 
 
2 詳細
 
 アーカイバの cpio にセキュリティ脆弱性が指摘されています。これは cpio で -O/-F オプションを使用した場合にパーミションが破壊され、そのためユーザーが意図しない読み書きが可能になってしまうという問題です。
 この問題の詳細については以下の情報を参照してください。
 
「CAN-1999-1572」 Common Vulnerabilities and Exposures
 
 
 アップデート後の cpio のバージョンは 2.5-1.2o1 に上がります。
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install cpio
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp