ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-16
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
postgresql-ogl
概要
ユーザーによる任意のライブラリ実行の可能性
危険度
2
 
 
 
2 詳細
 
 DBMS のPostgreSQL にセキュリティ脆弱性が指摘されています。これは DB 上の許可されていないユーザが、LOAD 拡張を用いて任意のライブラリを読み込ませることが可能になっていたという問題です。
 この問題の詳細については以下を参照してください。
 
pgsql-bugs ML への John Heasman 氏の投稿
 
 
 また postgresql の終了時に pid ファイルが破損している場合に停止できなくなる問題についても対処しています。
 アップデート後の postgresql 関連パッケージのバージョンは ARMA2.2 では 7.3.2r-3o401 に ARMA2.1 では 7.2.2-2o401 に上がります。
 
 
3 対処方法
 
 root になり以下のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install postgresql
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp