ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-13
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
mpg123
概要
任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 コマンドラインインタフェースの MPEG レイヤ 1/2/3 オーディオプレイヤーである mpg123 パッケージに脆弱性が報告されています。細工されたファイルの再生を行った場合に、バッファオーバーフローが発生し、任意のコードを実行される可能性が指摘されいます。
 詳細は以下の URL をご参照下さい。
 
「CAN-2004-0991」 Common Vulnerabilities and Exposures
 
「CAN-2004-1284」 Common Vulnerabilities and Exposures
 
 
 アップデート後のパッケージのバージョンは 0.59r-19o1 になります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行しパッケージのアップデートを行って下さい。ARMA 2.2 では mpg123-esd パッケージが、ARAM 2.1/2.0 では mpg123 パッケージがそれぞれデフォルトでインストールされます。
 ARAM 2.2
 
 
# apt-get update
# apt-get install mpg123-esd
 
 
 ARMA 2.1/2.0
 
 
# apt-get update
# apt-get install mpg123
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp