ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2005-11
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
ethereal-ogl
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 ネットワークトラフィック分析ツールである ethereal に複数のセキュリティ上の問題が発見されています。悪意をもって細工されたパケットを受けとった場合に DoS を被ったり任意のコードを実行される可能性が指摘されてます。
 意識的に ethereal を動作させない限り問題が起きることはありませんが、常用的に ethereal を使用している場合はリモートからの任意のコード実行につながる可能性もありますのでアップデートをおこなってください。
 
 
(1)
COPS パケットの解析で無限ループに陥いる可能性があります。
 
(2)
DLSw パケットの解析でプロセスが異常終了する可能性があります。
 
(3)
DNP パケットの解析でメモリの内容を破壊する可能性があります。
 
(4)
Gnutella パケットの解析でプロセスが異常終了する可能性があります。
 
(5)
MMSE の解析でメモリ開放に誤りがあります。
 
(6)
X11 プロコトルの解析にバッファオーバーフロー脆弱性が指摘されています。細工されたパケットを解析した場合に任意のコードを実行される可能性があります。
 
 
 詳細は以下の URL をご参照ください。
 
「enpa-sa-00017」Ethereal Security Advisories
 
「CAN-2005-0006」 Common Vulnerabilities and Exposures
 
「CAN-2005-0007」 Common Vulnerabilities and Exposures
 
「CAN-2005-0008」 Common Vulnerabilities and Exposures
 
「CAN-2005-0009」 Common Vulnerabilities and Exposures
 
「CAN-2005-0010」 Common Vulnerabilities and Exposures
 
「CAN-2005-0084」 Common Vulnerabilities and Exposures
 
 
 アップデート後の関連パッケージのバージョンは 0.10.9-1o101 になります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行してください。
 
 
# apt-get update
# apt-get install ethereal 
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp