ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-87
 
 
1 サマリ
 
 
対象システム
ARMA2.2
パッケージ
libgd
概要
任意コード実行の可能性
危険度
1
 
 
 
2 詳細
 
 画像生成ライブラリ GD の PNG 形式ファイル処理部分にバッファオーバーフロー脆弱性が指摘されています。細工をされた PNG 形式のファイルを処理した場合に GD ライブラリをしたアプリケーションの権限で任意のコードを実行される可能性があります。 この問題についてより詳しい情報は以下を参照してください。
 
「CAN-2004-0990」 Common Vulnerabilities and Exposures
 
 
 
 アップデート後の GD 関連パッケージのバージョンは 1.8.4-32o101 となります。
 
 
3 対処方法
 
 root 権限で以下のコマンドを実行しパッケージのアップデートをおこなって下さい。
 
 
# apt-get update 
# apt-get install libgd1-xpm
 
 
 他 GD パッケージを導入している場合はそれのアップデートをおこなって下さい。デフォルトではインストールされてませんが、ARMA Net リポジトリからインストール可能な GD 関連のパッケージは以下のものがあります。
 
 
 
libgd1-noxpm, libgd-dev, libgd1, libgd-xpm-dev, libgd-noxpm-dev
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp