ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-75
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
libpng, libpng3
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 PNG 形式の画像を扱いライブラリの libpng に整数オーバーフロー脆弱性が複数報告されています。細工された不正なファイルを外部から受けとった場合に libpng を用いたアプリケーションを経由しての任意コードの実行、 DoS 攻撃につながる可能性もあります。詳細は以下の URL をご参照下さい。
 
「CAN-2004-0955」 Common Vulnerabilities and Exposures
 
 
 ARMA 2.1 では libpng バージョン 1.0.12-4o401, libpng3 バージョン 1.2.1-1.1.woody.9 で対処しています。 ARMA 2.2 では libpng3 バージョン 1.2.5-10o301, libpng2 バージョン 1.0.15-6o101 で対処しています。
 
 
3 対処方法
 
 ARMA 2.1 をご利用の場合は以下のコマンドでパッケージのアップデートをおこなって下さい。
 
 
# apt-get update
# apt-get install libpng2 libpng3
 
 
 ARMA 2.2 をご利用の場合は以下のコマンドでパッケージのアップデートをおこなって下さい。
 
 
# apt-get update
# apt-get install libpng2 libpng12-0 
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp