ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-61
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
imagemagick
概要
任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 imagemagick にバッファオーバーフロー脆弱性が報告されいます。悪意をもって細工をされた BMP 形式のファイルを読み込んだ場合に任意のコードを実行される可能性があります。
 詳細は以下の URL をご参照下さい。
 
「CAN-2004-0827」 Common Vulnerabilities and Exposures
 
 
 
 
3 対処方法
 
 ARMA 2.0, 2.1 では imagemagick-ogl 5.4.6.3-2o201で、 ARMA 2.2 では imagemagick-ogl 5.5.7.9-1o101 で対応を行なっています。以下のコマンドでパッケージのアップデートを行って下さい。
 
 
# apt-get update
# apt-get install imagemagick
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp