ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-55-1
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
qt-x11-free-ogl
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 本アラートは 8/25公開の OSA-2004-55 の訂正情報となります。OSA-2004-55 に於いてARMA2.0,2.1 と ARMA 2.2 でインストールするパッケージの名前が入れ替わるという誤りがありました。ユーザー様にご迷惑をおかけしたことを深くお詫び申し上げるとともに対処方法を以下のように訂正いたします。
 KDE などのライブラリとして幅広く利用されている GUI ツールキット Qt の画像処理部分に複数の脆弱性が発見されています。細工された GIF, XPM, BMP の形式の画像を読み込んだ場合に任意のコードを実行される可能性が指摘されています。
 詳細は以下の URL をご参照下さい。
 
SUSE Security Announcement: qt3 (SUSE-SA:2004:027)
 
「CAN-2004-0691」 Common Vulnerabilities and Exposures
 
「CAN-2004-0692」 Common Vulnerabilities and Exposures
 
「CAN-2004-0693」 Common Vulnerabilities and Exposures
 
 
 
 
3 対処方法
 
 ARMA 2.0, 2.1 では qt-x11-free-ogl 3.0.5-4o201 で対応を行っています。root 権限で以下のコマンドを実行しパッケージのアップデートを行って下さい。
 
 
# apt-get install libqt3 libqt3-mt
 
 
 ARMA 2.2 では qt-x11-free-ogl 3.1.1-7o801 で対応を行っています。root 権限で以下のコマンドを実行しパッケージのアップデートを行って下さい。
 
 
# apt-get install libqt3c102-mt
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp