ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-5
 
 
1 サマリ
 
 
対象システム
ARMA2.2
パッケージ
kdepim-ogl
概要
ユーザー権限で任意コード実行の可能性
危険度
1
 
 
 
2 詳細
 
 VCF 形式のファイル読み込み処理にバッファオーバーフロー脆弱性が発見されています。不正な形式の VCF ファイルを読んだ場合に kdepim を実行したユーザーの権限で任意のコードを実行される可能性があります。
 詳細は以下の URL をご参照ください。
 
「CAN-2003-0925」 Common Vulnerabilities and Exposures
 
「VCF file information reader vulnerability 」 KDE Security Advisory
 
 
 
 
3 対処方法
 
 ARMA 2.2 では kdepim-kfile-plugins_3.1.1-1o201 でこの問題に対応しています。root 権限で以下のコマンドを実行しパッケージのアップデートを行って下さい。
 
 
# apt-get update
# apt-get install kdepim-kfile-plugins 
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp