ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 4.0

ARMA 3.0 マニュアル(ご参考用)

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-104
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
imlib, imlib+png2
概要
外部から任意コード実行の可能性
危険度
2
 
 
 
2 詳細
 
 imlib 系の画像ライブラリに複数のバッファオーバーフロー脆弱性が指摘されています。 悪意をもって細工をされた画像を imlib をリンクしたアプリケーションが読み込んだ場合に任意のコードを実行される可能性があります。
 詳細は以下の URL をご参照下さい。
 
 
「CAN-2004-1025」 Common Vulnerabilities and Exposures
 
「CAN-2004-1026」 Common Vulnerabilities and Exposures
 
 
 ARMA 2.0, ARMA 2.1 では imlib-ogl の関連パッケージのバージョンは 1.9.14-2woody2o1 になります。ARMA 2.2 では imlib-ogl の関連パッケージのバージョンは 1.9.14-12o201 に、 imlib+png2-ogl の関連パッケージのバージョンは 1.9.14-13o201 になります。
 
 
3 対処方法
 
 ARAM 2.0, 2.1 の場合は root 権限で以下のコマンドを実行しアップデートをおこなって下さい。
 
 
# apt-get update
# apt-get install  imlib1 gdk-imlib1
 
 
 ARAM 2.2 の場合は root 権限で以下のコマンドを実行しアップデートをおこなって下さい。
 
 
# apt-get update
# apt-get install imlib2 gdk-imlib1
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp