ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2004-102
 
 
1 サマリ
 
 
対象システム
ARMA2.0,ARMA2.1,ARMA2.2
パッケージ
debmake
概要
ファイルの上書きの可能性
危険度
1
 
 
 
2 詳細
 
 deb パッケージ開発支援ツールの debmake にセキュリティ脆弱性が指摘されています。これは不適切な一時ファイルの生成があったため、悪用された場合にローカルから任意のファイルを上書きされてしまう可能性がある、という問題です。
 この問題についての詳細は以下の情報を参照してください。
 
「DSA-615-1 debmake -- insecure temporary files」
 
 
 アップデート後の debmake パッケージのバージョンは、ARMA2.2 では 3.7.2-0o101 に、ARMA2.1 では 3.6.10.woody.1-0o1 に上がります。
 
 
3 対処方法
 
 本パッケージは deb パッケージ開発用ですので、通常の用途では削除していただいてもかまいません。削除する場合は、root になり以下のようにします。
 
 
# apt-get remove debmake
 
 
 アップデートする場合は以下のように実行してください。
 
 
# apt-get update
# apt-get install debmake
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp