ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

 OSA-2003-16
 
 
 1 サマリ
 
 
 
 
対象システム
ARMA2.0,ARMA2.1
 
 
 
パッケージ
samba-ja
 
 
 
概要
外部から任意コード実行の可能性
 
 
 
危険度
3
 
 
 
 
 2 詳細
 
 samba-ja に以下の脆弱性が発見されています。
 
 
(1)
バッファオーバーフロー脆弱性
 
SMB/CIFS のパケットフラグメント再構築ルーチンにバッファオーバーラン脆弱性が発見されました。この脆弱性を悪用することで外部から root 権限で任意のコマンドを実行される可能性があります。
 
 
(2)
システムファイル上書きの可能性
 
ファイルを書き込み時の chown の実行に競合条件があり、ローカ ユーザがシステムファイルの上書きを行える可能性があります。
 
 
 詳細は以下の URL をご参照下さい。
 
 
「CAN-2003-0085」 Common Vulnerabilities and Exposures
 
 
 
「CAN-2003-0086」 Common Vulnerabilities and Exposures
 
 
 
「DSA-262」 Debian Security Advisory
 
 
 
 
 
 3 対処方法
 
 ARMA 2.x では samba-ja-ogl_2.2.7a-ja1.1-1o100 以降でこの問題に対処しています。以下のコマンドでパッケージのアップデートを行って下さい。
 
 
# apt-get update
# apt-get install samba-ja
 
 
  
 swat もお使いの場合は、続けて以下のようにインストールしてください。
  
 
 
 
# apt-get install swat-i18n
 
 
 
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp