ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

 OSA-2003-13
 
 
 1 サマリ
 
 
 
 
対象システム
ARMA2.0,ARMA2.1
 
 
 
パッケージ
file
 
 
 
概要
任意コードの実行可能性
 
 
 
危険度
1
 
 
 
 
 2 詳細
 
 file コマンドにバッファオーバーフロー脆弱性が発見されています。細工された ELF フォーマットのファイルを入力した場合、file コマンドを実行したユーザの権限で任意のコマンドを実行される可能性があります。
 詳細は以下の URL をご参照下さい。
 
 
「DSA-260」 Debian Security Advisory
 
 
 
「CAN-2003-0102」 Common Vulnerabilities and Exposures
 
 
 
 
 
 3 対処方法
 
 ARMA 2.x では file_3.37-3.1.woody.1o1 以降でこの問題に対処しています。最新の file を以下のコマンドでインストールしてください。
 
 
# apt-get update
# apt-get install file
 
 
 
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp