ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2011-37
 
 
1 サマリ
 
 
対象システム
ARMA3.0
パッケージ
libmodplug
概要
S3Mトラッカーファイルを介した任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 モジュール音源ライブラリの libmodplug にセキュリティ脆弱性が指摘されています。これは libmodplug を使用したアプリケーションが悪意を持って細工された S3M トラッカーファイルを処理した場合に任意のコードを実行させられてしまう可能性がある、という問題です。
 この問題のより詳しい情報については下記を参照してください。
 
「DSA-2226-1 -- buffer overflow」
 
 
 アップデート後の libmodplug 関連パッケージのバージョンは 1:0.8.8.2-3o1 に上がります。
 
 
3 対処方法
 
 root になり下記のようにアップデートをおこなってください。
 
 
# apt-get update
# apt-get install libmodplug1
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp