ARMA
           ARMA Net           製品とサポート           通信販売           会社概要           求人情報       
ARMA 3.0

ARMA 3.0 マニュアル

プレインストール PC

個人・小規模サイト
向けサポート
(パッケージ付属)


よくいただくお問い
合わせについて


対応ハードウェア情報

法人向け各種サービス

OSA-2008-36
 
 
1 サマリ
 
 
対象システム
ARMA2.1,ARMA2.2
パッケージ
python2.2-ogl, python2.1-ogl
概要
任意のコード実行の可能性
危険度
1
 
 
 
2 詳細
 
 スクリプト言語 Python にセキュリティ脆弱性が指摘されています。悪意をもって細工をされた入力があった場合に任意のコードを実行されてしまう可能性があります。
 この問題の詳細についは以下の URL をご参照ください。
 
「CVE-2007-2052」 Common Vulnerabilities and Exposures
 
「CVE-2007-4965」 Common Vulnerabilities and Exposures
 
 
 
 ARMA 2.2 では python2.2 パッケージのアップデートが必要です。アップデート後の関連パッケージのバージョンは 2.2.2-5o501 になります。ARMA 2.1 では python2.1 及び python2.2 パッケージのアップデートが必要です。アップデート後の関連パッケージのバージョンは 2.2.1-5o801、 2.1.3-3.4o201 になります。
 
 
3 対処方法
 
 ARMA 2.2 をご利用の場合は root 権限で以下のコマンドを実行して下さい。
 
 
# apt-get update
# apt-get install python2.2
 
 
 ARMA 2.1 をご利用の場合は root 権限で以下のコマンドを実行して下さい。
 
 
# apt-get update
# apt-get install python2.1 python2.2
 

COPYRIGHT (C)2018, オモイカネ株式会社 (Omoikane Inc.)
E-mail: info@omoikane.co.jp